Back to overview
Downtime
STS Cloud / ProposalPath Unavailable
Jun 15, 2026 at 11:02pm UTC
Affected services
STS Cloud / ProposalPath
Resolved
Jun 15, 2026 at 11:15pm UTC
We identified the root cause and are now back up! Thank you for your patience.
Affected services
Created
Jun 15, 2026 at 11:02pm UTC
STS Cloud / ProposalPath is down for most users. We’re working to fix the problem as quickly as we can. We’ll share another update shortly.
Affected services